[Solved] Error Installing Nginx Modules for Virtualmin on Ubuntu

home Forums Server Administration [Solved] Error Installing Nginx Modules for Virtualmin on Ubuntu

Tagged: ,

This topic contains 0 replies, has 1 voice, and was last updated by  Tharindu Kumara 1 year ago.

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #6040

    Tharindu Kumara
    Keymaster

    I was building a cloud server for a client this morning when I encountered following error,

    E: Unable to locate package webmin-virtualmin-nginx
    E: Unable to locate package webmin-virtualmin-nginx-ssl

    I was building the server with my Ubuntu 16.04 LEMP stack tutorial. And I was trying to install nginx modules for Virtualmin with following command,

    apt-get install webmin-virtualmin-nginx webmin-virtualmin-nginx-ssl

    This is the first time I came across this error although it had been reported on comments section on a previous tutorial. The main reason for this error is that Virtualmin packages are missing on the sources list of the server. Adding them to sources.list file will fix the problem. So open it with nano text editor.

    nano /etc/apt/sources.list

    Append the file with following,

    deb http://software.virtualmin.com/gpl/debian/ virtualmin-squeeze main
    deb http://software.virtualmin.com/gpl/debian/ virtualmin-universal main

    Save (Ctrl + X) the file and update apt cache,

    apt-get update

    Now run the command to install modules again.

    apt-get install webmin-virtualmin-nginx webmin-virtualmin-nginx-ssl

    Issue should be fixed now.

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.