[Solved] Qtum wallet install error on Ubuntu 16.04 x64bit

home Forums Server Administration [Solved] Qtum wallet install error on Ubuntu 16.04 x64bit

Tagged: 

This topic contains 0 replies, has 1 voice, and was last updated by  Tharindu Kumara 2 months, 2 weeks ago.

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #6637

    Tharindu Kumara
    Keymaster

    I was trying to upgrade my Qtum wallet installed on Ubuntu 16.04 x64bit server. I use this VPS for staking. I tried to upgrade the wallet with a git pull and I ran into errors during the make command.

    This was the error I saw on CLI,
    [shell]CXX qtum/libbitcoin_server_a-storageresults.o
    qtum/storageresults.cpp: In member function ‘bool StorageResults::readResult(const h256&, std::vector<TransactionReceiptInfo>&)’:
    qtum/storageresults.cpp:121:130: error: ‘NoInformation’ is not a member of ‘dev::eth::TransactionException’
    1 ? static_cast<dev::eth::TransactionException>(tris.excepted[j]) : dev::eth::T
    ^
    Makefile:9510: recipe for target ‘qtum/libbitcoin_server_a-storageresults.o’ failed
    make[2]: *** [qtum/libbitcoin_server_a-storageresults.o] Error 1
    make[2]: Leaving directory ‘/root/qtum/src’
    Makefile:13716: recipe for target ‘all-recursive’ failed
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory ‘/root/qtum/src’
    Makefile:694: recipe for target ‘all-recursive’ failed
    make: *** [all-recursive] Error 1[/shell]

    after investigating about this error online for a while, I realized that this is a common issues on new installs and upgrade for wallet version 0.14.15. Lots of folks reported this on github and developers had responded. You can fix this by running following command,

    [shell]git submodule update[/shell]

    Source: #508

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.